Author Topic: Possible FIX to "No data received from server" Error  (Read 6986 times)

0 Members and 1 Guest are viewing this topic.

Offline katarina1

  • Trade Count: (0)
  • Posting Member
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 23
  • Drum rocks
    • View Profile
    • HowHubRocks
Re: Possible FIX to "No data received from server" Error
« Reply #30 on: September 08, 2008, 07:07:27 AM »
Maybe this helps...
I asked my admin, host about this and received reply:

_________________

> Hello,

> Please be informed that the site  was consuming
> the CPU usage beyond the allowable secure server limit.
> We are restricting the resource usage of the users scripts to maintain
> servers' stability. We are running a script on the server which disables
> the site for some time if it exceed this maximum allowable resource limit.

> This was causing the 500 error you were receiving at your end.
> If you experience further issues, you may need to optimize
> your PHP scripts at /lead/wp-admin/ so that they use server resources
> within the allowed range assigned to your plan or you can rent VPS or own
> server by your host (anyway your PHP script can work better).Regards,
> Rachit
> Technical Support
____________________________________________________________________
Kathy

Offline wwday3

  • Trade Count: (0)
  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 7
  • Posts: 337
  • Do the impossible
    • View Profile
    • WallyDay.com
  • Skype: wwday3
Re: Possible FIX to "No data received from server" Error
« Reply #31 on: September 08, 2008, 11:30:26 AM »
Reasonable explanation. If there are plugins that try to do something when the post is created, and those plugins exceed the allotted server time, you've got a possible explanation.

So, I got it again today (twice) after having no issues for several days. I looked at some logs and found this error/warning message twice.

09/08/08 12:05:43 - http://rpc.pingomatic.com/ could not be pinged. Error message: “transport error - HTTP status code was not 200”

I also checked the XML Sitemap plugin and it did not finish the last time it ran. Rebuilding it manually seemed to work OK.

I'm not sure which action fires off first, though I'm guessing the ping since it comes with Wordpress. It would seem the "flow" in this case would be

1WL post
Ping
XML Sitemap
XMLRPC "return"

In reality any one of those processes could be causing the entire process to exceed the time limit.

Offline wwday3

  • Trade Count: (0)
  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 7
  • Posts: 337
  • Do the impossible
    • View Profile
    • WallyDay.com
  • Skype: wwday3
Re: Possible FIX to "No data received from server" Error
« Reply #32 on: September 09, 2008, 07:25:24 PM »
OK, got it again. I looked at the log for pings, and they were fine. However, XML sitemap did not finish. I clicked around a bit more, and saw nothing unusual.

What was odd is the error messages said how much memory the plugin tried to use, and how long the process took. Neither values exceeded my limits. Maybe something in the plugin "stack" took too long prior to the sitemap plugin firing, but I'm at a loss what it could be.

I think the best way to debug the issue was copy and send the error information to the XML sitemap folks to see what they can suggest.

JL Forums

Re: Possible FIX to "No data received from server" Error
« Reply #32 on: September 09, 2008, 07:25:24 PM »

Offline grace5

  • Trade Count: (0)
  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 112
    • View Profile
Re: Possible FIX to "No data received from server" Error
« Reply #33 on: September 13, 2008, 08:46:19 AM »
again for me... :-\


and it goes on and on and on

Offline wwday3

  • Trade Count: (0)
  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 7
  • Posts: 337
  • Do the impossible
    • View Profile
    • WallyDay.com
  • Skype: wwday3
Re: Possible FIX to "No data received from server" Error
« Reply #34 on: September 14, 2008, 08:47:39 PM »
I'm not sure if I'm nuts thinking this or not - but...

I haven't had the problem for several days now. And, since the last time I had a problem the rate of posting to my donor blog has slowed down. So, is it possible that initially the posts were simply coming too fast?

Offline b11

  • Trade Count: (0)
  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 1
    • View Profile
Re: Possible FIX to "No data received from server" Error
« Reply #35 on: September 24, 2008, 04:47:03 PM »
Hi Guys,

Two days in and I got the dreaded message.  I have deactivated all plugins, removed all pinging services and theoretically ready to go.   Now here is my question/requst:

To actively debug from our site, we have to know if our action has worked on the 1wl site.  Could we have a dummy post link on the front page of 1wl that we can activate to test if the server is responding or not?

Enjoy
b11
javascript:void(0);

Offline grace5

  • Trade Count: (0)
  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 112
    • View Profile
Re: Possible FIX to "No data received from server" Error
« Reply #36 on: September 24, 2008, 05:42:17 PM »
Mine comes and goes maybe every other week.I have made no changes

Offline wwday3

  • Trade Count: (0)
  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 7
  • Posts: 337
  • Do the impossible
    • View Profile
    • WallyDay.com
  • Skype: wwday3
Re: Possible FIX to "No data received from server" Error
« Reply #37 on: September 25, 2008, 05:16:59 PM »
Well, I haven't had an issue for a couple weeks now. My current plugins are exactly the same now as when I was getting the error. In fact, I activated a couple new ones (though, I doubt the new ones would affect anything at all).

I wonder if Jon "fixed" something or possibly allowed a higher error level?

Or maybe it's just sunspots :)

Offline rita

  • Trade Count: (0)
  • Posting Member
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 7
    • View Profile
Re: Possible FIX to "No data received from server" Error
« Reply #38 on: October 09, 2008, 07:26:08 AM »
I am getting the same error.


JL Forums

Re: Possible FIX to "No data received from server" Error
« Reply #38 on: October 09, 2008, 07:26:08 AM »

Offline elchocador

  • Trade Count: (0)
  • Posting Member
  • *
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 8
    • View Profile
Re: Possible FIX to "No data received from server" Error
« Reply #39 on: October 15, 2008, 01:36:59 AM »
I finally got mine to go away.  Don't use smart update pinger use a newer version called:
Ultimate plugins - smart update pinger

Its newer and has better logging.  Use default setup with no other
ping addresses unless you know they wont come back with errors.